Pb avec l'action "image-gallery"

Plus d'informations
il y a 1 an 1 mois - il y a 1 an 1 mois #206 par clend
clend a créé le sujet : Pb avec l'action "image-gallery"
Bonjour,

Admiratif de vos démos sur cette action qui peut aisément mieux éclairer un visiteur confronté à une image trop petite pour bien la lire -et d'un simple clic-, je fais des essais sans résultat aucun.
Voici mes codes de test :
echo '<img src="images/comprofiler/'.$arr[1].'">';

echo '<img src="images/comprofiler/880_5ae1cd20523ca.jpg">';

echo '{up image-gallery=images/comprofiler/".$arr[1]."}';

echo '{up image-gallery=images/comprofiler/880_5ae1cd20523ca.jpg}';
Je les insère dans un article Joomla bordé en haut et bas par les balises {source} & {/source} du plugin Sourcerer..
nb : cette méthode avec Sourcerer fonctionne bien pour d'autres actions de votre plugin Up. Et j'ai bien télécharger votre dernière version avec toutes les actions.

Résultat à l'exécution de ces 4 lignes de test : les 2 premières instructions donnent bien l'affichage de l'image attendue, les 2 dernières ne donnent pas de résultat. Tout en notant qu'elles ne provoquent aucune erreur. Visiblement, elles ne semblent pas être prises en compte.
Peut-être convient-il de préciser la prise en compte de plugin de contenu ! Mais dans ce cas, je ne vois pas comment paramétrer ceci dans un article Joomla.

Cordialement, et vives félicitations pour un tel travail.

Claude Lendrevie

ps: la variable $arr[1] contient le nom de l'image, sans son dossier
Dernière édition: il y a 1 an 1 mois par clend.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 1 mois #207 par lomart
lomart a répondu au sujet : Pb avec l'action "image-gallery"
Bonjour,

N'utilisant pas Sourcerer, je ne saurais répondre.
Peut-être l'ordre d’exécution des plugins. Mais les plugins de regularlabs étant system, il devraient être exécutés en premier
Autre solution, récupérer $arr[1] avec l'action php
Bonne journée

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 1 mois #208 par clend
clend a répondu au sujet : Pb avec l'action "image-gallery"
Je vous remercie pour cette réponse rapide.
Donc, je vais essayer la solution préconisée. Mais ce que je ne comprends pas, c'est que vos autres actions UP fonctionnent correctement avec Sourcerer ... mais pas celle-ci.
Cordialement.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 1 mois #209 par lomart
lomart a répondu au sujet : Pb avec l'action "image-gallery"
Essayez l'option debug pour voir ce que UP a compris
Si c'est $arr[1], c'est raté. Cela veut dire que sourcerer intervient après

Connexion ou Créer un compte pour participer à la conversation.