Pb avec l'option "table-fixe" depuis J3.9

Plus d'informations
il y a 1 an 1 jour #227 par clend
clend a créé le sujet : Pb avec l'option "table-fixe" depuis J3.9
Êtes-vous certain que l'outil UP est bien compatible avec la dernière version de Joomla ?
Car je constate depuis la dernière mise à jour en J3.9 que tous mes affichages de tables responsives ont toutes perdues le blocage de la ligne haute (description des colonnes) et de la colonne gauche quand on scrolle la table.
Par contre, le côté "responsive" est toujours bon.
Y aurait-il un paramétrage particulier à effectuer dans l'admin de J3.9 ?

Merci pour votre aide. Je cherche depuis bien des heures ... et ne trouve pas la moindre explication.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 1 jour #228 par lomart
lomart a répondu au sujet : Pb avec l'option "table-fixe" depuis J3.9
Bonsoir,

Le site de UP est en 3.9 et la page de démo fonctionne parfaitement
up.lomart.fr/demo/action-table-fixe

Que dit la console de votre navigateur ?

Vous pouvez indiquer une URL pour que je vois le problème.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 17 heures #229 par clend
clend a répondu au sujet : Pb avec l'option "table-fixe" depuis J3.9
Bonjour Loïc,

Voici quelques éléments de réponse:

1. la console est muette sur ce problème particulier, aucun dysfonctionnement si ce n'est la non fixation de la table affichée,
2. le contenu de la table est correct, mais elle est trop baladeuse quand on la scrolle !
3. j'utilise à 3 endroits différents de mon site votre plugin "UP" avec l'action "table-fixe", et je fais pour chacun le même constat,
4. ces 3 tables fonctionnaient parfaitement il y a quelques jours,
5. voici un lien pour visualiser le phénomène:

----> https://entreprises.tousenvoiture.com/communiquer/chercher-un-membre

ps: l'accès au site est protégé. Vous pouvez utiliser le code "demo11" (idem pour identifiant & mot de passe)

Je vous remercie bien sincèrement pour m'avoir répondu aussi vite.
Cordialement,
C. Lendrevie

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 15 heures #230 par lomart
lomart a répondu au sujet : Pb avec l'option "table-fixe" depuis J3.9
Bonjour,

Le script tableHeadFixer.js n'est pas chargé ou invisible. Peut-être un minifieur de script ?

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 14 heures #231 par clend
clend a répondu au sujet : Pb avec l'option "table-fixe" depuis J3.9
Re,

J'utilise en effet le plugin "jch optimize": je viens donc de le désactiver. Mais les résultats ne sont pas probants.
1. j'affiche des formulaires avec des bulles d'aide sur les rubriques particulières (définies dans des div css): en désactivant jch optimize, elles viennent s'afficher en dur !
2. et surtout cela ne résoud pas le pb signalé avec UP.

J'ai également protégé ce site avec "aesecure" dans ses fonctions de base. N'y aurait-il pas un rapport ?

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 13 heures #232 par lomart
lomart a répondu au sujet : Pb avec l'option "table-fixe" depuis J3.9
Votre table est trop compliquée pour le script qui ne s'y retrouve pas. Virer les scopes et faire des règles CSS pour le tableau au lieu de cette quantité de style inline (addcsshead est génial pour cela)
Pour info la balise center est obsolète : developer.mozilla.org/fr/docs/Web/HTML/Element/center

Quel est le shortcode qui encadre la table ?
Ajouter l'option debug au shortcode pour voir comment UP le comprend : up.lomart.fr/#debug

Connexion ou Créer un compte pour participer à la conversation.