Pour insérer du JS, CSS dans le head et du HTML à la position indiquée.

Module ne s'affiche pas sur toutes les dimensions mobiles

Plus d'informations
il y a 2 mois 3 semaines #2134 par iorbita
Bonsoir,
j’ai installé le module LM-Custom-SITE afin de pouvoir afficher un module en position grid1 sur mon template, le module doit s’afficher uniquement sur les smartphones et tablettes, cependant il y a un souci: le module s’affiche correctement sur les smartphones et tablettes, sauf sur les tablettes iPad qui vont de 9,7 pouces à 12,9 pouces.
En effet l’option debug de votre module n’affiche rien à côté de l’option mobile et j’ai l’erreur Test failed : mobile, tandis que pour les autres dimensions mobiles le chiffre 1 est bien présent.
Est-ce que par hasard une bibliothèque ne serait pas mise à jour?

Ce message contient des informations confidentielles


Merci,
Lorenzo

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 3 semaines #2135 par lomart
Bonsoir,

Le module utilise la fonction intéégrée du Joomla installé sur le site.
N'ayant pas ipad, je ne peux tester. Désolé

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 3 semaines #2136 par iorbita
ok merci… ayant un ipad et l’ayant essayé je confirme donc qu’il y a un souci pour ces formats, ce qui n’est pas négligeable…

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 3 semaines #2137 par lomart
Si j'en crois ce post, Apple aurait changé les règles.
developer.apple.com/forums/thread/738478

Une solution pourrait être :
1/ identifier la signature de l'ipad en mettant ce code dans le champ HTML d'un module custom sans aucune condition
Code:
{up php=echo $_SERVER["HTTP_USER_AGENT"];}

2/ filtrer les ipad, en utilisant dans la zone php un code de ce type :
Code:
echo (strpos($_SERVER['HTTP_USER_AGENT'], 'MSIE') !== FALSE || strpos($_SERVER['HTTP_USER_AGENT'], 'Trident') !== FALSE);

Au besoin, dupliquer le module. Pour un la condition "mobile uniquement" et pour l'autre l'autre avec le code (adapté) ci-dessus pour l'afficher uniquement sur les ipad

Bonne journée

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 3 semaines #2138 par iorbita
Bonjour et merci pour le code, mais hélas toujours rien...

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 3 semaines #2139 par iorbita
.... j'admets que c'est un peu la pagaille avec les user-agents, j'ai essayé de m'inspirer à partir de ce site mais rien ne passe

PS: petite remarque, il n'est plus possible d'utiliser les "actions rapides" du forum (créer, citer, éditer), il faut passer obligatoirement par "Réponse rapide" et puis "Aller à l'éditeur"

Connexion ou Créer un compte pour participer à la conversation.

Propulsé par Kunena